28 mar 2013

Ejer. repaso: switching + routing

Después del post más relajado de ayer, hoy toca un post-Pro y ya aviso que la próxima entrada no tendrá nada que ver con el mundo de la informática.... Espero que os sirva de algo y ya sabéis, sentiros libres para comentar, opinar, sugerir....

Este es uno de esos ejercicios que se inventa Juan para repasar, en este caso repasa los módulos 2 y 3 del CCNA, tiene de todo, EIGRP, VLANs, WiFi, VTP, STP, switches de capa 3.... ¿alguien da más?

Después del salto muestro todas las configuraciones de los distintos componetes:

------------------ PLANTA 1------------------

S1

enable
conf t
hostname S1

!vtp
vtp mode server
vtp domain planta1
vtp password cisco

!vlans
vlan 10
name empleados1
exit
vlan 20
name direccion1
exit
vlan 30
name servicios1
exit
vlan 40
name informatica1
exit
vlan 99
name nativa&admin1
exit

!interface al router
interface f0/1
no switchport
ip address 172.16.0.17 255.255.255.248
no shutdown

!enlace troncal
interface g0/2
switchport trunk encapsulation dot1q
switchport mode trunk
exit

!enlace lateral con otro sw3
interface g0/1
no switchport
ip address 172.16.0.1 255.255.255.248
no shutdown
exit

!configurar interfaces vlans con ips
interface vlan 10
ip address 172.17.0.1 255.255.255.128
no shutdown
exit
interface vlan 20
ip address 172.17.0.129 255.255.255.224
no shutdown
exit
interface vlan 30
ip address 172.17.0.161 255.255.255.224
no shutdown
exit
interface vlan 40
ip address 172.17.0.193 255.255.255.240
no shutdown
exit
interface vlan 99
ip address 172.17.0.209 255.255.255.252
no shutdown
exit

!asignamos puertos a vlans
interface range f0/2-11
switchport mode access
switchport access vlan 40
exit
interface range f0/12-24
switchport mode access
switchport access vlan 10
exit

!habilito enrutamiento
ip routing

!configuro enrutamiento
router eigrp 100
network 172.17.0.0
network 172.16.0.0
no auto-summary

!aplicamos seguridad a nivel de puerto (en Packet Tracer hay q ir uno a uno)
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

!RPVST
spanning-tree mode rapid-pvst

-----------

A1

enable
conf t
hostname A1

!vtp
vtp mode client
vtp domain planta1
vtp password cisco

!enlaces troncales
interface range g1/1-2
switchport mode trunk
exit

interface range f0/1-24
switchport mode access
switchport access vlan 10
exit

!aplicamos seguridad a nivel de puerto
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

-----------

A1b

enable
conf t
hostname A1b

!vtp
vtp mode client
vtp domain planta1
vtp password cisco

!enlaces troncales
interface range g1/1-2
switchport mode trunk
exit

interface range f0/1-24
switchport mode access
switchport access vlan 10
exit

!aplicamos seguridad a nivel de puerto
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

-----------

A1c

enable
conf t
hostname A1c

!vtp
vtp mode client
vtp domain planta1
vtp password cisco

!enlaces troncales
interface range g1/1-2
switchport mode trunk
exit

interface range f0/1-10
switchport mode access
switchport access vlan 20
exit

interface range f0/11-21
switchport mode access
switchport access vlan 20
exit

!aplicamos seguridad a nivel de puerto
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

-----------

A1d

enable
conf t
hostname A1d

!vtp
vtp mode client
vtp domain planta1
vtp password cisco

!enlaces troncales
interface range g1/1-2
switchport mode trunk
exit

interface range f0/1-10
switchport mode access
switchport access vlan 30
exit

interface range f0/11-21
switchport mode access
switchport access vlan 10
exit

!aplicamos seguridad a nivel de puerto
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

------------------ PLANTA 2------------------

S2

enable
conf t
hostname S2

!vtp
vtp mode server
vtp domain planta2
vtp password cisco

!vlans
vlan 10
name empleados2
exit
vlan 20
name direccion2
exit
vlan 30
name servicios2
exit
vlan 40
name informatica2
exit
vlan 99
name nativa&admin2
exit

!enlace troncal
interface f0/1
switchport trunk encapsulation dot1q
switchport mode trunk
exit

!enlace lateral con otro sw3
interface g0/1
no switchport
ip address 172.16.0.2 255.255.255.248
no shutdown
exit
interface g0/2
no switchport
ip address 172.16.0.9 255.255.255.248
no shutdown
exit

!configurar interfaces vlans con ips
interface vlan 10
ip address 172.17.1.1 255.255.255.128
no shutdown
exit
interface vlan 20
ip address 172.17.1.129 255.255.255.224
no shutdown
exit
interface vlan 30
ip address 172.17.1.161 255.255.255.224
no shutdown
exit
interface vlan 40
ip address 172.17.1.193 255.255.255.240
no shutdown
exit
interface vlan 99
ip address 172.17.1.209 255.255.255.252
no shutdown
exit

!asignamos puertos a vlans
interface range f0/2-11
switchport mode access
switchport access vlan 40
exit
interface range f0/12-24
switchport mode access
switchport access vlan 10
exit

!habilito enrutamiento
ip routing

!configuro enrutamiento
router eigrp 100
network 172.17.0.0
network 172.16.0.0
no auto-summary

!aplicamos seguridad a nivel de puerto (en Packet Tracer hay q ir uno a uno)
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

!RPVST
spanning-tree mode rapid-pvst

-----------

A2

enable
conf t
hostname A2

!vtp
vtp mode client
vtp domain planta2
vtp password cisco

!enlaces troncales
interface range g1/1-2
switchport mode trunk
exit

interface range f0/1-24
switchport mode access
switchport access vlan 10
exit

!aplicamos seguridad a nivel de puerto
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

!portFast (en los puertos de acceso conectados a pcs para permitir q se conecten de manera inmediata sin esperar convergencia spanning tree
interface f0/5
spanning-tree portFast
exit

-----------

A2b

enable
conf t
hostname A2b

!vtp
vtp mode client
vtp domain planta2
vtp password cisco

!enlaces troncales
interface range g1/1-2
switchport mode trunk
exit

interface range f0/1-24
switchport mode access
switchport access vlan 30
exit

!aplicamos seguridad a nivel de puerto
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

!portFast (en los puertos de acceso conectados a pcs para permitir q se conecten de manera inmediata sin esperar convergencia spanning tree
interface f0/5
spanning-tree portFast
exit


------------------ PLANTA 3------------------

S3

enable
conf t
hostname S3

!vtp
vtp mode server
vtp domain planta3
vtp password cisco

!vlans
vlan 10
name empleados3
exit
vlan 20
name direccion3
exit
vlan 30
name servicios3
exit
vlan 40
name informatica3
exit
vlan 99
name nativa&admin3
exit

!enlace troncal
interface f0/1
switchport trunk encapsulation dot1q
switchport mode trunk
exit

!enlace lateral con otro sw3
interface g0/1
no switchport
ip address 172.16.0.10 255.255.255.248
no shutdown
exit


!configurar interfaces vlans con ips
interface vlan 10
ip address 172.17.2.1 255.255.255.128
no shutdown
exit
interface vlan 20
ip address 172.17.2.129 255.255.255.224
no shutdown
exit
interface vlan 30
ip address 172.17.2.161 255.255.255.224
no shutdown
exit
interface vlan 40
ip address 172.17.2.193 255.255.255.240
no shutdown
exit
interface vlan 99
ip address 172.17.2.209 255.255.255.252
no shutdown
exit

!asignamos puertos a vlans
interface range f0/2-11
switchport mode access
switchport access vlan 40
exit
interface range f0/12-24
switchport mode access
switchport access vlan 10
exit

!habilito enrutamiento
ip routing

!configuro enrutamiento
router eigrp 100
network 172.17.0.0
network 172.16.0.0
no auto-summary

!aplicamos seguridad a nivel de puerto (en Packet Tracer hay q ir uno a uno)
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

!RPVST
spanning-tree mode rapid-pvst

-----------

A3

enable
conf t
hostname A3

!vtp
vtp mode client
vtp domain planta3
vtp password cisco

!enlaces troncales
interface range g1/1-2
switchport mode trunk
exit

interface range f0/1-24
switchport mode access
switchport access vlan 10
exit

!aplicamos seguridad a nivel de puerto
interface range f0/1-24
switchport port-security maximum 1
switchport port-security mac-address sticky
exit

------------------ ROUTER ------------------

enable
conf t
hostname R0

!interface al server (internet)
interface f0/1
ip address 80.20.15.1 255.255.255.0
no shutdown
exit

!interface al S1
interface f0/0
ip address 172.16.0.18 255.255.255.248
no shutdown
exit

!ruta por defecto
ip route 0.0.0.0 0.0.0.0 f0/1

!enrutamiento
route eigrp 100
network 172.16.0.0 0.0.0.31
network 80.15.20.0
no auto-summary
passive-interface f0/1
exit

1 comentario :

  1. jajaja no entiendo ná de ná ;-)
    Tienes una cosina para tí en mi blog http://acericuymandil.blogspot.com.es/2013/04/premio-one-lovely-blog-award.html
    Besín

    ResponderEliminar

Powered By Blogger

Marcadores

Seguidores